Improper access control in the Babelfish for PostgreSQL extension versions 1.2-1.5, 2.1-2.15, 3.1-3.12, 4.0-4.8, 5.1-5.4 may allow remote authenticated users to elevate their privileges. To remediate this issue, we recommend you upgrade to Babelfish for PostgreSQL extension versions 4.10, 5.6, 6.1 or later.

Project Subscriptions

Vendors Products
Babelfish-for-postgresql Subscribe
Advisories

No advisories yet.

Fixes

Solution

No solution given by the vendor.


Workaround

No workaround given by the vendor.

History

Tue, 03 Nov 2026 18:30:00 +0000

Type Values Removed Values Added
Description Improper access control in the Babelfish for PostgreSQL extension versions 1.2-1.5, 2.1-2.15, 3.1-3.12, 4.0-4.8, 5.1-5.4 may allow remote authenticated users to elevate their privileges. To remediate this issue, we recommend you upgrade to Babelfish for PostgreSQL extension versions 4.10, 5.6, 6.1 or later.
Title Babelfish for PostgreSQL Privilege Escalation
First Time appeared Aws
Aws babelfish-for-postgresql
Weaknesses CWE-266
CPEs cpe:2.3:a:aws:babelfish-for-postgresql:*:*:*:*:*:*:*:*
Vendors & Products Aws
Aws babelfish-for-postgresql
References
Metrics cvssV3_1

{'score': 8.8, 'vector': 'CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H'}

cvssV4_0

{'score': 8.7, 'vector': 'CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N'}


Projects

Sign in to view the affected projects.

cve-icon MITRE

Status: PUBLISHED

Assigner: AMZN

Published:

Updated: 2026-11-03T20:13:48.531Z

Reserved: 2026-10-30T16:59:28.086Z

Link: CVE-2026-119922

cve-icon Vulnrichment

No data.

cve-icon NVD

Status : Received

Published: 2026-11-03T19:17:57.020

Modified: 2026-11-03T19:17:57.020

Link: CVE-2026-119922

cve-icon Redhat

No data.

cve-icon OpenCVE Enrichment

Updated: 2026-11-03T20:15:14Z

Weaknesses